package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(?<SEPARATOR>[-.\/_]
)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4})(\k<SEPARATOR>)([D]{1,4}|[M]{1,4}|[Y]{2}|[Y]{4}))$`)
var str = `MMDDYY
MMMM_DD_YY
DD.MM.YYY
PP.LL.MMMM
YYYYDD__MMM
MP.DD.YYYY
MMDDYYYY
MDDYY
OO.DD.YY
DD.DDD.YYYY
MMM.DYY.YYY
MM.DDDD.YYYY
DD.MD.YYYY
MM.MM.YYYY
DD.DDD.DDD
D.MD.YYYY
MDYY`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}