# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-(?:(?<!\b[0-9]{4}-)|(?![0-9]{2}(?:[0-9]{2})?\b))/ /g;t' <<< "Studied b-tech from college in 2010-13
Studied b-tech from college in 2010-2013
Studied b-tech from college in 2010-13 at B-college
"