import Foundation
let pattern = #"-(?:(?<!\b[0-9]{4}-)|(?![0-9]{2}(?:[0-9]{2})?\b))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Studied b-tech from college in 2010-13
Studied b-tech from college in 2010-2013
Studied b-tech from college in 2010-13 at B-college
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)