re = /-(?:(?<!\b[0-9]{4}-)|(?![0-9]{2}(?:[0-9]{2})?\b))/
str = 'Studied b-tech from college in 2010-13
Studied b-tech from college in 2010-2013
Studied b-tech from college in 2010-13 at B-college
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result