const regex = new RegExp('-(?:(?<!\\b[0-9]{4}-)|(?![0-9]{2}(?:[0-9]{2})?\\b))', 'g')
const str = `Studied b-tech from college in 2010-13
Studied b-tech from college in 2010-2013
Studied b-tech from college in 2010-13 at B-college
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);