#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "-(?:(?<!\b[0-9]{4}-)|(?![0-9]{2}(?:[0-9]{2})?\b))"
Local $sString = "Studied b-tech from college in 2010-13" & @CRLF & _
"" & @CRLF & _
"Studied b-tech from college in 2010-2013" & @CRLF & _
"" & @CRLF & _
"Studied b-tech from college in 2010-13 at B-college" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)