$re = '/-(?:(?<!\b[0-9]{4}-)|(?![0-9]{2}(?:[0-9]{2})?\b))/';
$str = 'Studied b-tech from college in 2010-13
Studied b-tech from college in 2010-2013
Studied b-tech from college in 2010-13 at B-college
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;