using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(wasn)\S*\b(?:\S*([?!.,:;])\S*)?";
string substitution = @"\1n't\2";
string input = @"i really wasn aware and i wasnt aware at all. but i wasn't aware. just wasn't. this wasn45'e meant to be. it wasn@'re simple
Wasn&^$tt that nice?
You say wasnmmmt?
No, he wasn&#t#@$.
She wasn%#@t##, I know.
She wasn%#@t##,$#^ I know.";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}