# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(wasn)\S*\b(?:\S*([?!.,:;])\S*)?"
test_str = ("i really wasn aware and i wasnt aware at all. but i wasn't aware. just wasn't. this wasn45'e meant to be. it wasn@'re simple\n"
"Wasn&^$tt that nice?\n"
"You say wasnmmmt?\n"
"No, he wasn&#t#@$.\n"
"She wasn%#@t##, I know.\n"
"She wasn%#@t##,$#^ I know.")
subst = "\\1n't\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.