import Foundation
let pattern = #"\b(wasn)\S*\b(?:\S*([?!.,:;])\S*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ###"""
i really wasn aware and i wasnt aware at all. but i wasn't aware. just wasn't. this wasn45'e meant to be. it wasn@'re simple
Wasn&^$tt that nice?
You say wasnmmmt?
No, he wasn&#t#@$.
She wasn%#@t##, I know.
She wasn%#@t##,$#^ I know.
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1n't\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)