import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(wasn)\\S*\\b(?:\\S*([?!.,:;])\\S*)?";
final String string = "i really wasn aware and i wasnt aware at all. but i wasn't aware. just wasn't. this wasn45'e meant to be. it wasn@'re simple\n"
+ "Wasn&^$tt that nice?\n"
+ "You say wasnmmmt?\n"
+ "No, he wasn&#t#@$.\n"
+ "She wasn%#@t##, I know.\n"
+ "She wasn%#@t##,$#^ I know.";
final String subst = "\\1n't\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}