package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(wasn)\S*\b(?:\S*([?!.,:;])\S*)?`)
var str = `i really wasn aware and i wasnt aware at all. but i wasn't aware. just wasn't. this wasn45'e meant to be. it wasn@'re simple
Wasn&^$tt that nice?
You say wasnmmmt?
No, he wasn&#t#@$.
She wasn%#@t##, I know.
She wasn%#@t##,$#^ I know.`
var substitution = "\1n't\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}