$re = '/\b(wasn)\S*\b(?:\S*([?!.,:;])\S*)?/i';
$str = 'i really wasn aware and i wasnt aware at all. but i wasn\'t aware. just wasn\'t. this wasn45\'e meant to be. it wasn@\'re simple
Wasn&^$tt that nice?
You say wasnmmmt?
No, he wasn&#t#@$.
She wasn%#@t##, I know.
She wasn%#@t##,$#^ I know.';
$subst = "\1n't\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;