#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.{0,7}|[^f].{7}|.[^r].{6}|..[^i].{5}|...[^t].{4}|.{4}[^z]...|.{5}[^b]..|.{6}[^o].|.{7}[^x]|.{9,})@domain\.tld$"
Local $sString = "@domain.tld" & @CRLF & _
"1@domain.tld" & @CRLF & _
"abc@domain.tld" & @CRLF & _
"foobar@domain.tld" & @CRLF & _
"fritzbo@domain.tld" & @CRLF & _
"foobarba@domain.tld" & @CRLF & _
"fritzbox@domain.tld" & @CRLF & _
"aritzbox@domain.tld" & @CRLF & _
"frutzbox@domain.tld" & @CRLF & _
"fritzbot@domain.tld" & @CRLF & _
"fritzbox1@domain.tld" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")