$re = '/^(.{0,7}|[^f].{7}|.[^r].{6}|..[^i].{5}|...[^t].{4}|.{4}[^z]...|.{5}[^b]..|.{6}[^o].|.{7}[^x]|.{9,})@domain\.tld$/m';
$str = '@domain.tld
1@domain.tld
abc@domain.tld
foobar@domain.tld
fritzbo@domain.tld
foobarba@domain.tld
fritzbox@domain.tld
aritzbox@domain.tld
frutzbox@domain.tld
fritzbot@domain.tld
fritzbox1@domain.tld
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);