import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.{0,7}|[^f].{7}|.[^r].{6}|..[^i].{5}|...[^t].{4}|.{4}[^z]...|.{5}[^b]..|.{6}[^o].|.{7}[^x]|.{9,})@domain\\.tld$";
final String string = "@domain.tld\n"
+ "1@domain.tld\n"
+ "abc@domain.tld\n"
+ "foobar@domain.tld\n"
+ "fritzbo@domain.tld\n"
+ "foobarba@domain.tld\n"
+ "fritzbox@domain.tld\n"
+ "aritzbox@domain.tld\n"
+ "frutzbox@domain.tld\n"
+ "fritzbot@domain.tld\n"
+ "fritzbox1@domain.tld\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}