use strict;
my $str = '@domain.tld
1@domain.tld
abc@domain.tld
foobar@domain.tld
fritzbo@domain.tld
foobarba@domain.tld
fritzbox@domain.tld
aritzbox@domain.tld
frutzbox@domain.tld
fritzbot@domain.tld
fritzbox1@domain.tld
';
my $regex = qr/^(.{0,7}|[^f].{7}|.[^r].{6}|..[^i].{5}|...[^t].{4}|.{4}[^z]...|.{5}[^b]..|.{6}[^o].|.{7}[^x]|.{9,})@domain\.tld$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}