// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.{0,7}|[^f].{7}|.[^r].{6}|..[^i].{5}|...[^t].{4}|.{4}[^z]...|.{5}[^b]..|.{6}[^o].|.{7}[^x]|.{9,})@domain\.tld$").unwrap();
let string = "@domain.tld
1@domain.tld
abc@domain.tld
foobar@domain.tld
fritzbo@domain.tld
foobarba@domain.tld
fritzbox@domain.tld
aritzbox@domain.tld
frutzbox@domain.tld
fritzbot@domain.tld
fritzbox1@domain.tld
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}