using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.{0,7}|[^f].{7}|.[^r].{6}|..[^i].{5}|...[^t].{4}|.{4}[^z]...|.{5}[^b]..|.{6}[^o].|.{7}[^x]|.{9,})@domain\.tld$";
string input = @"@domain.tld
1@domain.tld
abc@domain.tld
foobar@domain.tld
fritzbo@domain.tld
foobarba@domain.tld
fritzbox@domain.tld
aritzbox@domain.tld
frutzbox@domain.tld
fritzbot@domain.tld
fritzbox1@domain.tld
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}