# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^_\n]*)_([^_\n]*)(_.*)?|(.*)(?<!-)-(?!-)(\w+)(.*)/$2--$1$3$4$6--$5/g;t' <<< "foo_bar_something-like_this-me
bar--foo_something-like_this-me--
something-like--bar--foo_this-me----
this-me------something-like--bar--foo--
--this-me------something--bar--foo----like
----this------something--bar--foo----like--me
"