import Foundation
let pattern = #"([^_\n]*)_([^_\n]*)(_.*)?|(.*)(?<!-)-(?!-)(\w+)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
foo_bar_something-like_this-me
bar--foo_something-like_this-me--
something-like--bar--foo_this-me----
this-me------something-like--bar--foo--
--this-me------something--bar--foo----like
----this------something--bar--foo----like--me
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2--$1$3$4$6--$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)