use strict;
my $str = 'foo_bar_something-like_this-me
bar--foo_something-like_this-me--
something-like--bar--foo_this-me----
this-me------something-like--bar--foo--
--this-me------something--bar--foo----like
----this------something--bar--foo----like--me
';
my $regex = qr/([^_\n]*)_([^_\n]*)(_.*)?|(.*)(?<!-)-(?!-)(\w+)(.*)/p;
my $subst = '$2--$1$3$4$6--$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";