using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^_\n]*)_([^_\n]*)(_.*)?|(.*)(?<!-)-(?!-)(\w+)(.*)";
string substitution = @"$2--$1$3$4$6--$5";
string input = @"foo_bar_something-like_this-me
bar--foo_something-like_this-me--
something-like--bar--foo_this-me----
this-me------something-like--bar--foo--
--this-me------something--bar--foo----like
----this------something--bar--foo----like--me
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}