#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<draw(?:\s*|)(?:\s([^<>]*)|)(?:\/>|>([^<>]*)<\/draw>)"
Local $sString = "<draw/>" & @CRLF & _
"<draw />" & @CRLF & _
"<draw class="idiot"/>" & @CRLF & _
"<draw disabled>im a funny not</draw>" & @CRLF & _
"<draw disabled><im a funny not></draw>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")