using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<draw(?:\s*|)(?:\s([^<>]*)|)(?:\/>|>([^<>]*)<\/draw>)";
string input = @"<draw/>
<draw />
<draw class=""idiot""/>
<draw disabled>im a funny not</draw>
<draw disabled><im a funny not></draw>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}