$re = '/<draw(?:\s*|)(?:\s([^<>]*)|)(?:\/>|>([^<>]*)<\/draw>)/m';
$str = '<draw/>
<draw />
<draw class="idiot"/>
<draw disabled>im a funny not</draw>
<draw disabled><im a funny not></draw>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);