package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<draw(?:\s*|)(?:\s([^<>]*)|)(?:\/>|>([^<>]*)<\/draw>)`)
var str = `<draw/>
<draw />
<draw class="idiot"/>
<draw disabled>im a funny not</draw>
<draw disabled><im a funny not></draw>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}