import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<draw(?:\\s*|)(?:\\s([^<>]*)|)(?:\\/>|>([^<>]*)<\\/draw>)";
final String string = "<draw/>\n"
+ "<draw />\n"
+ "<draw class=\"idiot\"/>\n"
+ "<draw disabled>im a funny not</draw>\n"
+ "<draw disabled><im a funny not></draw>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}