re = /<draw(?:\s*|)(?:\s([^<>]*)|)(?:\/>|>([^<>]*)<\/draw>)/m
str = '<draw/>
<draw />
<draw class="idiot"/>
<draw disabled>im a funny not</draw>
<draw disabled><im a funny not></draw>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end