using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\d+x\d+\.\w+$).+$";
string input = @"100x100pass-this-string.jpg
and-pass-this.png
100x100.jpg-anyletters.jpg
test-string-150x150.png
teststring.com-150x150.jpg
anyletters-100x100.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}