import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\d+x\\d+\\.\\w+$).+$";
final String string = "100x100pass-this-string.jpg\n"
+ "and-pass-this.png\n"
+ "100x100.jpg-anyletters.jpg\n\n"
+ "test-string-150x150.png\n"
+ "teststring.com-150x150.jpg\n"
+ "anyletters-100x100.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}