re = /^(?!.*\d+x\d+\.\w+$).+$/m
str = '100x100pass-this-string.jpg
and-pass-this.png
100x100.jpg-anyletters.jpg
test-string-150x150.png
teststring.com-150x150.jpg
anyletters-100x100.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end