use strict;
my $str = '100x100pass-this-string.jpg
and-pass-this.png
100x100.jpg-anyletters.jpg
test-string-150x150.png
teststring.com-150x150.jpg
anyletters-100x100.jpg';
my $regex = qr/^(?!.*\d+x\d+\.\w+$).+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}