const regex = /^(?!.*\d+x\d+\.\w+$).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\d+x\\d+\\.\\w+$).+$', 'gm')
const str = `100x100pass-this-string.jpg
and-pass-this.png
100x100.jpg-anyletters.jpg
test-string-150x150.png
teststring.com-150x150.jpg
anyletters-100x100.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}