#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)dear\s+(mr|mrs|miss|ms)\b[^£]+(£[\d,.]+)(?:\D|\d(?![\d.]*%))+([\d.]+%)(?:\D|\d(?![\d.]*%))+([\d.]+%)"
Local $sString = ""Dear Mr case 1","the value of my property is £500,000.00 and it was built in 1980", " & @CRLF & _
""The protected percentage is 13% for 2 years", "The interest rate is fixed for 2 years at 4.8%"" & @CRLF & _
""Dear Mrs case 1","the value of my property is £40,000.93 and it was built in 1980", " & @CRLF & _
""The protected percentage is 13.25% for 2 years", "The interest rate is fixed for 2 years at 4%"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")