const regex = new RegExp('dear\\s+(mr|mrs|miss|ms)\\b[^£]+(£[\\d,.]+)(?:\\D|\\d(?![\\d.]*%))+([\\d.]+%)(?:\\D|\\d(?![\\d.]*%))+([\\d.]+%)', 'gmi')
const str = `"Dear Mr case 1","the value of my property is £500,000.00 and it was built in 1980",
"The protected percentage is 13% for 2 years", "The interest rate is fixed for 2 years at 4.8%"
"Dear Mrs case 1","the value of my property is £40,000.93 and it was built in 1980",
"The protected percentage is 13.25% for 2 years", "The interest rate is fixed for 2 years at 4%"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}