import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dear\\s+(mr|mrs|miss|ms)\\b[^£]+(£[\\d,.]+)(?:\\D|\\d(?![\\d.]*%))+([\\d.]+%)(?:\\D|\\d(?![\\d.]*%))+([\\d.]+%)";
final String string = "\"Dear Mr case 1\",\"the value of my property is £500,000.00 and it was built in 1980\", \n"
+ "\"The protected percentage is 13% for 2 years\", \"The interest rate is fixed for 2 years at 4.8%\"\n"
+ "\"Dear Mrs case 1\",\"the value of my property is £40,000.93 and it was built in 1980\", \n"
+ "\"The protected percentage is 13.25% for 2 years\", \"The interest rate is fixed for 2 years at 4%\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}