use strict;
my $str = '"Dear Mr case 1","the value of my property is £500,000.00 and it was built in 1980",
"The protected percentage is 13% for 2 years", "The interest rate is fixed for 2 years at 4.8%"
"Dear Mrs case 1","the value of my property is £40,000.93 and it was built in 1980",
"The protected percentage is 13.25% for 2 years", "The interest rate is fixed for 2 years at 4%"
';
my $regex = qr/dear\s+(mr|mrs|miss|ms)\b[^£]+(£[\d,.]+)(?:\D|\d(?![\d.]*%))+([\d.]+%)(?:\D|\d(?![\d.]*%))+([\d.]+%)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}