using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"dear\s+(mr|mrs|miss|ms)\b[^£]+(£[\d,.]+)(?:\D|\d(?![\d.]*%))+([\d.]+%)(?:\D|\d(?![\d.]*%))+([\d.]+%)";
string input = @"""Dear Mr case 1"",""the value of my property is £500,000.00 and it was built in 1980"",
""The protected percentage is 13% for 2 years"", ""The interest rate is fixed for 2 years at 4.8%""
""Dear Mrs case 1"",""the value of my property is £40,000.93 and it was built in 1980"",
""The protected percentage is 13.25% for 2 years"", ""The interest rate is fixed for 2 years at 4%""
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}