#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)^(WSPRD2.*?DELESTAT(?:.*?\n)*?)"
Local $sString = "" & @CRLF & _
"WSPRD3#/TO/PATH/TASK5" & @CRLF & _
" PRIORITY 60" & @CRLF & _
"NEEDS 1 MASTER#AAA0RTYU" & @CRLF & _
"NEEDS 1 MASTER#DELESTAT" & @CRLF & _
"NEEDS 1 MASTER#RAAA1JK" & @CRLF & _
"NEEDS 1 MASTER#RAAADDDB" & @CRLF & _
"NEEDS 8 MASTER#ZR" & @CRLF & _
"NEEDS 1 MASTER#SRBBB3" & @CRLF & _
"" & @CRLF & _
" FOLLOWS GET_INPUT" & @CRLF & _
"" & @CRLF & _
"END" & @CRLF & _
"" & @CRLF & _
"WSPRD2#/TO/PATH/TASK6" & @CRLF & _
" PRIORITY 60" & @CRLF & _
"NEEDS 1 MASTER#AAA0RETU" & @CRLF & _
"NEEDS 1 MASTER#DELESTAT" & @CRLF & _
"NEEDS 1 MASTER#RAAACCC" & @CRLF & _
"NEEDS 1 MASTER#RAAADDD" & @CRLF & _
"NEEDS 8 MASTER#ZR" & @CRLF & _
"NEEDS 1 MASTER#SRBBB2" & @CRLF & _
"" & @CRLF & _
" FOLLOWS GET_INPUT" & @CRLF & _
"" & @CRLF & _
"END" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"WSPRD2#/TO/PATH/TASK9" & @CRLF & _
" PRIORITY 60" & @CRLF & _
"NEEDS 1 MASTER#AAA0RETU" & @CRLF & _
"NEEDS 1 MASTER#DELESTAT" & @CRLF & _
"NEEDS 1 MASTER#RAAACCC" & @CRLF & _
"NEEDS 1 MASTER#RAAADDD" & @CRLF & _
"NEEDS 8 MASTER#ZR" & @CRLF & _
"NEEDS 1 MASTER#SRBBB2" & @CRLF & _
"" & @CRLF & _
" FOLLOWS GET_INPUT" & @CRLF & _
"" & @CRLF & _
"END" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"WSPRD4#/TO/PATH/TASK8" & @CRLF & _
" PRIORITY 60" & @CRLF & _
"NEEDS 1 MASTER#AAA0RETU" & @CRLF & _
"NEEDS 1 MASTER#DELESTAT" & @CRLF & _
"NEEDS 1 MASTER#RAAACCC" & @CRLF & _
"NEEDS 1 MASTER#RAAADDD" & @CRLF & _
"NEEDS 8 MASTER#ZR" & @CRLF & _
"NEEDS 1 MASTER#SRBBB2" & @CRLF & _
"" & @CRLF & _
" FOLLOWS GET_INPUT" & @CRLF & _
"" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")