// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)^(WSPRD2.*?DELESTAT(?:.*?\n)*?)").unwrap();
let string = "
WSPRD3#/TO/PATH/TASK5
PRIORITY 60
NEEDS 1 MASTER#AAA0RTYU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAA1JK
NEEDS 1 MASTER#RAAADDDB
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB3
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK6
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK9
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END
WSPRD4#/TO/PATH/TASK8
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}