using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)^(WSPRD2.*?DELESTAT(?:.*?\n)*?)";
string input = @"
WSPRD3#/TO/PATH/TASK5
PRIORITY 60
NEEDS 1 MASTER#AAA0RTYU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAA1JK
NEEDS 1 MASTER#RAAADDDB
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB3
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK6
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK9
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END
WSPRD4#/TO/PATH/TASK8
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}