import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^(WSPRD2.*?DELESTAT(?:.*?\\n)*?)";
final String string = "\n"
+ "WSPRD3#/TO/PATH/TASK5\n"
+ " PRIORITY 60\n"
+ "NEEDS 1 MASTER#AAA0RTYU\n"
+ "NEEDS 1 MASTER#DELESTAT\n"
+ "NEEDS 1 MASTER#RAAA1JK\n"
+ "NEEDS 1 MASTER#RAAADDDB\n"
+ "NEEDS 8 MASTER#ZR\n"
+ "NEEDS 1 MASTER#SRBBB3\n\n"
+ " FOLLOWS GET_INPUT\n\n"
+ "END\n\n"
+ "WSPRD2#/TO/PATH/TASK6\n"
+ " PRIORITY 60\n"
+ "NEEDS 1 MASTER#AAA0RETU\n"
+ "NEEDS 1 MASTER#DELESTAT\n"
+ "NEEDS 1 MASTER#RAAACCC\n"
+ "NEEDS 1 MASTER#RAAADDD\n"
+ "NEEDS 8 MASTER#ZR\n"
+ "NEEDS 1 MASTER#SRBBB2\n\n"
+ " FOLLOWS GET_INPUT\n\n"
+ "END\n\n\n"
+ "WSPRD2#/TO/PATH/TASK9\n"
+ " PRIORITY 60\n"
+ "NEEDS 1 MASTER#AAA0RETU\n"
+ "NEEDS 1 MASTER#DELESTAT\n"
+ "NEEDS 1 MASTER#RAAACCC\n"
+ "NEEDS 1 MASTER#RAAADDD\n"
+ "NEEDS 8 MASTER#ZR\n"
+ "NEEDS 1 MASTER#SRBBB2\n\n"
+ " FOLLOWS GET_INPUT\n\n"
+ "END\n\n\n"
+ "WSPRD4#/TO/PATH/TASK8\n"
+ " PRIORITY 60\n"
+ "NEEDS 1 MASTER#AAA0RETU\n"
+ "NEEDS 1 MASTER#DELESTAT\n"
+ "NEEDS 1 MASTER#RAAACCC\n"
+ "NEEDS 1 MASTER#RAAADDD\n"
+ "NEEDS 8 MASTER#ZR\n"
+ "NEEDS 1 MASTER#SRBBB2\n\n"
+ " FOLLOWS GET_INPUT\n\n"
+ "END";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}