const regex = /(?s)^(WSPRD2.*?DELESTAT(?:.*?\n)*?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)^(WSPRD2.*?DELESTAT(?:.*?\\n)*?)', 'gm')
const str = `
WSPRD3#/TO/PATH/TASK5
PRIORITY 60
NEEDS 1 MASTER#AAA0RTYU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAA1JK
NEEDS 1 MASTER#RAAADDDB
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB3
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK6
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK9
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END
WSPRD4#/TO/PATH/TASK8
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
NEEDS 1 MASTER#RAAADDD
NEEDS 8 MASTER#ZR
NEEDS 1 MASTER#SRBBB2
FOLLOWS GET_INPUT
END`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}