import re
regex = re.compile(r"(?s)^(WSPRD2.*?DELESTAT(?:.*?\n)*?)", flags=re.MULTILINE)
test_str = ("\n"
"WSPRD3#/TO/PATH/TASK5\n"
" PRIORITY 60\n"
"NEEDS 1 MASTER#AAA0RTYU\n"
"NEEDS 1 MASTER#DELESTAT\n"
"NEEDS 1 MASTER#RAAA1JK\n"
"NEEDS 1 MASTER#RAAADDDB\n"
"NEEDS 8 MASTER#ZR\n"
"NEEDS 1 MASTER#SRBBB3\n\n"
" FOLLOWS GET_INPUT\n\n"
"END\n\n"
"WSPRD2#/TO/PATH/TASK6\n"
" PRIORITY 60\n"
"NEEDS 1 MASTER#AAA0RETU\n"
"NEEDS 1 MASTER#DELESTAT\n"
"NEEDS 1 MASTER#RAAACCC\n"
"NEEDS 1 MASTER#RAAADDD\n"
"NEEDS 8 MASTER#ZR\n"
"NEEDS 1 MASTER#SRBBB2\n\n"
" FOLLOWS GET_INPUT\n\n"
"END\n\n\n"
"WSPRD2#/TO/PATH/TASK9\n"
" PRIORITY 60\n"
"NEEDS 1 MASTER#AAA0RETU\n"
"NEEDS 1 MASTER#DELESTAT\n"
"NEEDS 1 MASTER#RAAACCC\n"
"NEEDS 1 MASTER#RAAADDD\n"
"NEEDS 8 MASTER#ZR\n"
"NEEDS 1 MASTER#SRBBB2\n\n"
" FOLLOWS GET_INPUT\n\n"
"END\n\n\n"
"WSPRD4#/TO/PATH/TASK8\n"
" PRIORITY 60\n"
"NEEDS 1 MASTER#AAA0RETU\n"
"NEEDS 1 MASTER#DELESTAT\n"
"NEEDS 1 MASTER#RAAACCC\n"
"NEEDS 1 MASTER#RAAADDD\n"
"NEEDS 8 MASTER#ZR\n"
"NEEDS 1 MASTER#SRBBB2\n\n"
" FOLLOWS GET_INPUT\n\n"
"END")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")