# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"[^"{}]+":\s*{[^{}]*"_href":[^{}]*}//gm;t' <<< "[{
\"name\": \"Test\",
\"junkAttributeA\": {
\"_href\": \"string\",
\"_type\": \"string\"
},
\"junkAttributeB\": {
\"_href\": \"string\",
\"_type\": \"string\"
}
}]"