re = /"[^"{}]+":\s*{[^{}]*"_href":[^{}]*}/m
str = '[{
"name": "Test",
"junkAttributeA": {
"_href": "string",
"_type": "string"
},
"junkAttributeB": {
"_href": "string",
"_type": "string"
}
}]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result