// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"{}]+":\s*{[^{}]*"_href":[^{}]*}"#).unwrap();
let string = "[{
\"name\": \"Test\",
\"junkAttributeA\": {
\"_href\": \"string\",
\"_type\": \"string\"
},
\"junkAttributeB\": {
\"_href\": \"string\",
\"_type\": \"string\"
}
}]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}