$re = '/"[^"{}]+":\s*{[^{}]*"_href":[^{}]*}/m';
$str = '[{
"name": "Test",
"junkAttributeA": {
"_href": "string",
"_type": "string"
},
"junkAttributeB": {
"_href": "string",
"_type": "string"
}
}]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;