use strict;
my $str = '[{
"name": "Test",
"junkAttributeA": {
"_href": "string",
"_type": "string"
},
"junkAttributeB": {
"_href": "string",
"_type": "string"
}
}]';
my $regex = qr/"[^"{}]+":\s*{[^{}]*"_href":[^{}]*}/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";